"This device's number was not found in your account"

Home Forums Phone Defender for Android – Beta Test 2019 "This device's number was not found in your account"

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #6018
    davidpmax
    Participant

    I’m on a Sprint LG V40, Android 8.1.0.
    When I try to login, it says “This device’s number was not found in your account”

    #6023
    mark_marasch
    Participant

    davidpmax,

    Please try this updated version, I think it will fix that problem for you:
    [Link Removed]

    We’re trying this out with a few people running into this problem and we’ll be pushing this out to everybody soon.

    Thanks!

    Mark W. Marasch
    Ethical Developer Group

    • This reply was modified 1 year, 4 months ago by mark_marasch.
    #6027
    davidpmax
    Participant

    That link doesn’t appear to work.
    I’ve got v1.4 installed now.

    #6033
    acidus
    Participant

    I’m getting the same error message on Verizon Wireless:
    “This device’s number was not found in your account”

    Confirming the link above does not work.

    I also have v1.4 installed now.

    #6039
    mark_marasch
    Participant

    davidpmax and acidus,

    I’ve confirmed that you have the latest and found out my link was outdated. I’m checking to see if we have logging for your accounts showing what information was passed. There may be some delays in getting a response with the holiday.

    Thanks for your patience!

    Mark W. Marasch
    Ethical Developer Group

    #6047
    bosscube
    Participant

    Same issue here. Samsung Galaxy Note 9 on Xfinity Mobile (AKA Verizon). Bummer!

    #6064
    mark_marasch
    Participant

    This should fix the issues in this thread. We’ve found the issue with how different phones report their numbers and made some changes to the code so that the numbers are reported to Jolly Roger’s system in a format that will be recognize.

    Version 1.5 incorporates these changes and is now available here:
    https://jollyrogertelephone.com/android-defender-app/

    Thanks!

    Mark W. Marasch
    Ethical Developer Group

    #6067
    bosscube
    Participant

    Confirmed: I can now login. Thanks!! 👌🏼

    #6070
    davidpmax
    Participant

    I installed the new version, and now I get “Username/password not recognized. Please try again.”
    Same username/password I’m using for logging in to post this comment right now.

    #6073
    davidpmax
    Participant

    BTW, in the last week, Sprint released the Android 9 updated for my LG V40, so when I started this thread, I was at Android version 8.1.0, but now I’m on version 9, if that makes a difference.

    #6077
    mark_marasch
    Participant

    davidpmax,

    It should work fine under Android 9, but please let us know how it goes for you.

    Android 10 introduces an architecture change that will still allow the app to be installed but keeps it from being selected as the default phone app, which keeps the app from doing its job.

    Thanks!
    Mark

    #6102
    acidus
    Participant

    Working for me now.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.